分类 博客程序相关文件 下的文章

传奇原阳[置顶]

十二丞相有史纂, 张良刺秦有遗篇
还有毛遂制的剑, 千古一绝原阳县!
原阳北倚太行山, 原阳南临黄河岸,
人杰地灵震中原, 原阳大米天下传.
原武镇上玲珑塔, 历经沧桑数百年!
古博浪沙在城关, 秦皇遇刺在这边,
伴随时过境也迁, 玲珑宝塔歪着站'
古博浪沙少人烟, 正阳仰天空余叹;
--------往事越千年!
原阳覆地又翻天, 今天有了大发展;
到了原阳吃烩面, 不吃烩面真遗憾!
原阳烩面最正宗! 孟江四辈和平安,
吃罢烩面吃米线, 5号小东和李元!
还有一个样洋红, 搬到博大的贴边,
不吃米线吃馄吨, 赵记字号数十年,
南街烧饼惹人馋, 都说里面有大烟!
原阳不少专卖店, 学生都有名牌穿;
以纯邦威和森马, 别克沃特跟乔丹!
听说李宁也来了, 就在工商局贴边,
南街有个商贸城, 北街有个县医院,
西街有个大转盘, 东街有个加油站,
娃哈哈能洗温泉, 夏家院里看破砖!
电影院前新时代, 房租可贵钱难赚/
原阳超市有三家, 华隆新运和量贩,
夜个华隆才破产, 另外两家看式办,
要是物美价又廉, 原阳人民才喜欢,
光哪假货来哄俺, 卷住铺盖也滚蛋!
县委破房才掀完, 博大广场开始建,
温州老板眼真尖, 净赚原阳父老钱'
咱给他们盖别墅, 咱给他们买本田!
原阳经济有隐患, 投资过热很明显,
物价成倍往上翻, 百姓敢怒不敢言!
半碗糊涂8毛钱, 一斤鸡蛋三快三!
再来把咱一中谈, 母校荒草尘漫天!
次地空余复习班, 黄河大厦在对面,
自由市场真热闹, 小吃街也不简单,
复习班在正中间, 阵阵叫卖透心寒!
曾经操场最浪漫, 几对鸳鸯戏水面,
曾经操场最黑暗, 打架斗殴不间断!
一中新区也不仙, 一人考上十人BAN!
纪律松弛没人管, 成群结队往这转!
晚上集体爽夜市, 稀里哗啦出校园,
电话一打'富康'来, 场面那是真壮观!
要是经典人爆满, 大众海龙或一点~
原阳奇闻上千万, 黄河滔滔水不完!
备战高考时间短, 切莫虚度误华年!
今天忽然来灵感, 胡说八道成笑谈!
他日我若为知县, 敢叫原阳换新天!

Typecho 关闭非中文语系的评论

做独立博客最烦的就是垃圾评论多得让人删得手软,而其中大部分的垃圾评论是英文语系的,所以屏蔽英文屏蔽必定可以有效地降低垃圾评论的数量,当然前提是博客是面前国内用户的,在typecho博客上,willin通过修改代码设置了关闭非中文语系的评论,下面是博客吧转载过来的操作方法。

关闭typecho非中文语系的评论

在当前主题模板中找到comments.php文件,在其中找到以下代码

<?php if($this->allow('comment')): ?>

将代码修改为

<?php if($this->allow('comment') && stripos($_SERVER['HTTP_ACCEPT_LANGUAGE'], 'zh') > -1): ?>

保存文件即可。

提示:其实现原理是通过增加一个浏览器语系的判断,如果是中文的话才能留下评论。正常中文操作系统中安装的浏览器基本都是中文语系的,如果自己使用的不是中文语系的,可以在浏览器语言选项中加入中文(zh, zh-cn, zh-tw, zh-hk 皆可),然后刷新浏览器,就可评论。

Typecho 文章密码保护显示标题方法

Typecho使用密码加密的日志,默认连标题都加密了,直接显示“此内容被密码保护”。修改Typecho加密日志显示标题的方法:

打开文件:var/Widget/Abstract/Contents.php

找到

$value['title'] = _t('此内容被密码保护');
前面加入 //$value['title'] = _t('此内容被密码保护');
注释掉这行就ok了。实现效果见Magento批量添加长尾搜索词。

弄了半夜终于用上了Typecho

之前的博客程序是Z-Blog,一直感觉主题不太好看。大多主题安装都是收费的。闲来无事在网上发现了Typecho博客程序。了解了一下Typecho博客程序小巧强劲。大多是博主都在使用。先是本地安装调试了几天。感觉很好。今天晚上心血来潮(换程序)搞了半夜都没有搞好。百度一查Typecho1.1正式版程序

Typecho 最新版为1.1(17.10.30)

安装环境要求

PHP 5.4 以上

MySQL, PostgreSQL, SQLite 任意一种数据库支持,并在 PHP 中安装了相关扩展

CURL 扩展支持

mbstring 或 iconv 扩展支持

服务器PHP版本低于5.4时,安装会报错。

用服务器是阿里云 云共享空间。

PHP版本支持 5.2 5.3 5.4 5.5

MySQL 5.1

我的这个服务器符合Typecho1.1正式版本 程序的要求。试了PHP5.4 5.5 不知道为什么就是安装不上。(现在还没有搞明白)

在Typecho论坛查询相关资料,发现有伙伴发帖(typecho1.1可以在PHP 5.3环境下用)

答案是:

不能

如果需要在PHP版本低于5.4的服务器上安装最新版的typecho,以下是一种可行的方法:

1.到GitHub下载Typecho 1.0(14.10.10)版的安装包,用其中的install.php文件和install文件夹覆盖1.1版的同名文件和文件夹。

2.执行http://域名/install.php安装(新手参考官方安装文档安装)。